+1 vote
in Operating Systems by (75.1k points)

While installing 'pdftools' from Rstudio, I get the following error message and it fails to install 'pdftools'. I am using Ubuntu 22; adding PPA  'libpoppler-cpp-dev' to repository also fails. Is there anyway to install 'libpoppler-cpp-dev' so that I can install 'pdftools' for R.

Configuration failed to find 'poppler-cpp' system library. Try installing:

 * On Ubuntu 16.04 or 18.04 use this PPA:

    sudo add-apt-repository -y ppa:cran/poppler

    sudo apt-get update

    sudo apt-get install -y libpoppler-cpp-dev

1 Answer

+1 vote
by (59.8k points)
selected by
 
Best answer

The error "Configuration failed to find 'poppler-cpp' system library" usually means that the software can't locate the Poppler library, which is needed for working with PDF files. This could be because the library isn't installed on your computer or because some important files are missing.

Here are the commands to install "poppler-cpp" on Ubuntu 22:

sudo apt update 

sudo apt install libpoppler-cpp-dev

Once "poppler-cpp" is installed, you can install 'pdftools' from Rstudio.

Related questions


...